summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2013-10-19 15:39:15 -0400
committerPaul Smith <psmith@gnu.org>2013-10-19 15:39:15 -0400
commit107ab16bf6f0bb912aab2d72e019f20e11a03aba (patch)
treedbcf0e781246f3a52c323cd71d65ee2605c4a85f /Makefile.am
parent07f2666b91c0083a36135c9893305b2a620e3b38 (diff)
downloadgunmake-107ab16bf6f0bb912aab2d72e019f20e11a03aba.tar.gz
[SV 40240] Use configure info to build load test shared libs
* tests/config-flags.pm.in: A new file containing variable assignments for the test suite; these variables are set by configure to contain the values detected there for compilers, flags, etc. * tests/run_make_tests.pl: Require the config-flags.pm file * tests/scripts/features/load, tests/scripts/features/loadapi: Use the configure-provided values when building the shared test library. * configure.ac: Replace tests/config-flags.pm.in * Makefile.am: Make sure tests/config-flags.pm is up to date
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6303d96..e2c0fe9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -172,7 +172,7 @@ loadavg_LDADD = @GETLOADAVG_LIBS@
#
MAKETESTFLAGS =
-check-regression:
+check-regression: tests/config-flags.pm
@if test -f '$(srcdir)/tests/run_make_tests'; then \
if $(PERL) -v >/dev/null 2>&1; then \
case `cd '$(srcdir)'; pwd` in `pwd`) : ;; \