summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2005-05-10 01:38:18 +0000
committerPaul Smith <psmith@gnu.org>2005-05-10 01:38:18 +0000
commit26d8d00cb77f0d71f72d4f61e7f38009dbef9715 (patch)
tree90030c239cea27ff9dc8049eea04b67244d7e898 /Makefile.am
parente4c14a675ca6df1f31aac5d4571be695d76a7fd0 (diff)
downloadgunmake-26d8d00cb77f0d71f72d4f61e7f38009dbef9715.tar.gz
Fixes to allow "make dist" etc. to work again.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 0877aa2..c8c7cd4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,14 +3,15 @@
AUTOMAKE_OPTIONS = 1.8 dist-bzip2 check-news ansi2knr
ACLOCAL_AMFLAGS = -I config
-SUBDIRS = glob config po doc
# Only process if target is MS-Windows
if WINDOWSENV
- SUBDIRS += w32
- W32INC := -I $(top_srcdir)/w32/include
- W32LIB := -Lw32 -lw32
+ MAYBE_W32 = w32
+ W32INC = -I $(top_srcdir)/w32/include
+ W32LIB = -Lw32 -lw32
endif
+SUBDIRS = glob config po doc $(MAYBE_W32)
+
bin_PROGRAMS = make
if USE_CUSTOMS
@@ -25,7 +26,7 @@ make_SOURCES = ar.c arscan.c commands.c default.c dir.c expand.c file.c \
misc.c read.c remake.c $(remote) rule.c signame.c \
variable.c version.c vpath.c hash.c
-EXTRA_make_SOURCES = remote-stub.c remote-cstms.c
+EXTRA_make_SOURCES = vmsjobs.c remote-stub.c remote-cstms.c
noinst_HEADERS = commands.h dep.h filedef.h job.h make.h rule.h variable.h \
debug.h getopt.h gettext.h hash.h