summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
committerPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
commit8572d6adf04d397505770b0b0d5cfd91cf6a92a8 (patch)
tree8e590714da1d480bef4ca2afbe81fa95c2624de6 /Makefile.am
parent4a073980236d80b47a24c5caea3ece4e9bb7e044 (diff)
downloadgunmake-8572d6adf04d397505770b0b0d5cfd91cf6a92a8.tar.gz
Major updates in preparation for 3.80.
New version of the manual, put into the doc subdir. Enhancements: $(eval ...) and $(value ...) functions, various bug fixes, etc. See the ChangeLog. More to come.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c393a96..5d70f42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
AUTOMAKE_OPTIONS = 1.6 dist-bzip2
ACLOCAL_AMFLAGS = -I config
-SUBDIRS = glob config po
+SUBDIRS = glob config po doc
bin_PROGRAMS = make
@@ -23,10 +23,9 @@ EXTRA_make_SOURCES = remote-stub.c remote-cstms.c
noinst_HEADERS = commands.h dep.h filedef.h job.h make.h rule.h variable.h \
debug.h getopt.h gettext.h
-make_LDADD = @LIBOBJS@ @ALLOCA@ $(GLOBLIB) @GETLOADAVG_LIBS@
+make_LDADD = @LIBOBJS@ @ALLOCA@ $(GLOBLIB) @GETLOADAVG_LIBS@ @LIBINTL@
man_MANS = make.1
-info_TEXINFOS = make.texinfo
DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\" @DEFS@
@@ -40,7 +39,7 @@ AM_CPPFLAGS = $(GLOBINC)
EXTRA_DIST = README build.sh.in $(man_MANS)\
README.customs\
- make-stds.texi SCOPTIONS SMakefile\
+ SCOPTIONS SMakefile\
README.Amiga Makefile.ami config.ami make.lnk amiga.c amiga.h\
README.DOS Makefile.DOS configure.bat dosbuild.bat configh.dos\
README.W32 NMakefile config.h.W32 build_w32.bat subproc.bat\
@@ -50,6 +49,13 @@ EXTRA_DIST = README build.sh.in $(man_MANS)\
MAKE_HOST = @MAKE_HOST@
+# Forward targets
+
+html pdf:
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
+
+.PHONY: html pdf
+
# --------------- Internationalization Section
localedir = $(datadir)/locale