summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2005-02-26 01:41:48 +0000
committerPaul Smith <psmith@gnu.org>2005-02-26 01:41:48 +0000
commit9d153cc1b1e467cd6245755c32f78efbd62142c2 (patch)
tree229919252d0b4a25e1e5c00d80ab744fbe5b5c81 /Makefile.am
parent6d995b036e714ea3d61112ebc582b0671cc36e77 (diff)
downloadgunmake-9d153cc1b1e467cd6245755c32f78efbd62142c2.tar.gz
Add configure operations to support MINGW on Windows.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b3d85c5..0877aa2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,12 @@ AUTOMAKE_OPTIONS = 1.8 dist-bzip2 check-news ansi2knr
ACLOCAL_AMFLAGS = -I config
SUBDIRS = glob config po doc
+# Only process if target is MS-Windows
+if WINDOWSENV
+ SUBDIRS += w32
+ W32INC := -I $(top_srcdir)/w32/include
+ W32LIB := -Lw32 -lw32
+endif
bin_PROGRAMS = make
@@ -25,12 +31,20 @@ noinst_HEADERS = commands.h dep.h filedef.h job.h make.h rule.h variable.h \
debug.h getopt.h gettext.h hash.h
make_LDADD = @LIBOBJS@ @ALLOCA@ $(GLOBLIB) @GETLOADAVG_LIBS@ @LIBINTL@
+# Only process if target is MS-Windows
+if WINDOWSENV
+ make_LDADD += $(W32LIB)
+endif
man_MANS = make.1
DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\" @DEFS@
AM_CPPFLAGS = $(GLOBINC)
+# Only process if target is MS-Windows
+if WINDOWSENV
+ AM_CPPFLAGS += $(W32INC)
+endif
# Extra stuff to include in the distribution.