summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-09-12 22:15:58 +0000
committerPaul Smith <psmith@gnu.org>2002-09-12 22:15:58 +0000
commitd7ebcadadbfc100af64cc4c18580a6373bd52738 (patch)
treec66f531406bd1e48a85a02fc70e8688d9b4221f3 /Makefile.am
parent4a11acf04705a07b78d8ddf71cfc90ce2607cdd8 (diff)
downloadgunmake-d7ebcadadbfc100af64cc4c18580a6373bd52738.tar.gz
Fixups for the release. One bug fix, some automake complaint fixes,
and a function return type fix for older systems.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2afb6b9..e00cc6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,10 +121,13 @@ check-loadavg: loadavg
# The loadavg function is invoked during "make check" to test getloadavg.
noinst_PROGRAMS = loadavg
-loadavg_SOURCES = getloadavg.c
+loadavg_SOURCES = loadavg.c
loadavg_CFLAGS = -DTEST
loadavg_LDADD = @GETLOADAVG_LIBS@
+loadavg.c: $(srcdir)/getloadavg.c
+ cp $(srcdir)/getloadavg.c loadavg.c
+
# > check-regression
#
# Look for the make test suite, and run it if found and we can find perl.