summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2013-10-19 12:21:09 -0400
committerPaul Smith <psmith@gnu.org>2013-10-19 12:24:14 -0400
commitf4b746b8c23c257574b44e6bc0ad830c754f0c6b (patch)
tree89712cdb955967aea092bfa7ef1d33da5c723681 /Makefile.am
parentd7f25cfda5806cb67dba012f0f9c715a9dcd65e4 (diff)
downloadgunmake-f4b746b8c23c257574b44e6bc0ad830c754f0c6b.tar.gz
[SV 40254] Modify build.sh to work properly with Guile support.
* guile.c (guile_gmake_setup) [HAVE_GUILE]: Define a stub function when Guile support is not enabled. * main.c (main) [HAVE_GUILE]: Always invoke guile_gmake_setup(). * Makefile.am: Make guile.c standard, not optional. * build.template: Add the Guile compiler and linker flags.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8cbfe7e..6303d96 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,15 +40,11 @@ else
endif
make_SOURCES = ar.c arscan.c commands.c default.c dir.c expand.c file.c \
- function.c getopt.c getopt1.c implicit.c job.c load.c \
+ function.c getopt.c getopt1.c guile.c implicit.c job.c load.c \
loadapi.c main.c misc.c output.c read.c remake.c rule.c \
signame.c strcache.c variable.c version.c vpath.c hash.c \
$(remote)
-if HAVE_GUILE
- make_SOURCES += guile.c
-endif
-
EXTRA_make_SOURCES = vmsjobs.c remote-stub.c remote-cstms.c
noinst_HEADERS = commands.h dep.h filedef.h job.h makeint.h rule.h variable.h \