summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
committerPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
commit8572d6adf04d397505770b0b0d5cfd91cf6a92a8 (patch)
tree8e590714da1d480bef4ca2afbe81fa95c2624de6 /doc/Makefile.am
parent4a073980236d80b47a24c5caea3ece4e9bb7e044 (diff)
downloadgunmake-8572d6adf04d397505770b0b0d5cfd91cf6a92a8.tar.gz
Major updates in preparation for 3.80.
New version of the manual, put into the doc subdir. Enhancements: $(eval ...) and $(value ...) functions, various bug fixes, etc. See the ChangeLog. More to come.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..bf979c8
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to create Makefile.in.
+
+## Makefile for GNU make documentation.
+## Copyright 2002 Free Software Foundation, Inc.
+
+TEXI2HTML = texi2html
+TEXI2HTML_FLAGS = -split_chapter
+
+info_TEXINFOS = make.texi
+make_TEXINFOS = fdl.texi make-stds.texi
+
+CLEANFILES = make*.html make*.pdf
+
+## ----------------------------- ##
+## Other documentation formats. ##
+## ----------------------------- ##
+
+html: make_1.html
+
+make_1.html: $(info_TEXINFOS) $(make_TEXINFOS)
+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/make.texi
+
+
+pdf: make.pdf
+
+make.pdf: $(info_TEXINFOS) $(make_TEXINFOS)
+ $(TEXI2DVI) --pdf --batch $(srcdir)/make.texi
+
+.PHONY: html pdf