aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/icingaweb2.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2017-02-01 20:11:38 +0300
committerIgor Pashev <pashev.igor@gmail.com>2017-02-01 21:00:44 +0300
commit809a35ba85df0a202d26d9ee8cfa474c7eecdf99 (patch)
tree4e72d07fabf4d8bbcd1c731dc54a7745bc88db92 /modules/apps/icingaweb2.nix
parent092d712689eec989003ec23f5ac19da9134acea4 (diff)
downloadnixsap-809a35ba85df0a202d26d9ee8cfa474c7eecdf99.tar.gz
php-fpm: make use of home directory
Potentially breaking, these options are removed: pool.user, pool.listen.owner, pool.listen.mode. Since socket owner cannot be set now, nginx needs to belong to the appropriate PHP-FPM group.
Diffstat (limited to 'modules/apps/icingaweb2.nix')
-rw-r--r--modules/apps/icingaweb2.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/modules/apps/icingaweb2.nix b/modules/apps/icingaweb2.nix
index 852c546..fad0509 100644
--- a/modules/apps/icingaweb2.nix
+++ b/modules/apps/icingaweb2.nix
@@ -161,7 +161,6 @@ let
));
defaultPool = {
- listen.owner = config.nixsap.apps.nginx.user;
pm.max_children = 10;
pm.max_requests = 1000;
pm.max_spare_servers = 5;
@@ -363,11 +362,13 @@ in {
config = mkIf cfg.enable {
nixsap.deployment.keyrings.root = keys;
+ users.users.${config.nixsap.apps.nginx.user}.extraGroups = [ cfg.user ];
users.users.icingaweb2.extraGroups = mkIf localIcinga [ config.nixsap.apps.icinga2.commandGroup ];
nixsap.apps.php-fpm.icingaweb2 = mkOverride 0 {
+ inherit (cfg) user;
inherit (cfg.php-fpm) package;
- pool = recursiveUpdate defaultPool (cfg.php-fpm.pool // { user = cfg.user ;});
+ pool = recursiveUpdate defaultPool cfg.php-fpm.pool;
};
nixsap.apps.nginx.conf.http.servers.icingaweb2 = ''