aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/icingaweb2.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:21:52 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:27:34 +0300
commitb40e89f23632d3fabe95bbf214bb77a32567b3d9 (patch)
treea76f8222e93152f3886008ad6ef7b6eadbe401ba /modules/apps/icingaweb2.nix
parentb24ae5d345aa84bdba20efbb4a14ddfc9bf39873 (diff)
downloadnixsap-b40e89f23632d3fabe95bbf214bb77a32567b3d9.tar.gz
Do not filter keys at application level
It's done in the nixsap.deployment module See b24ae5d345aa84bdba20efbb4a14ddfc9bf39873
Diffstat (limited to 'modules/apps/icingaweb2.nix')
-rw-r--r--modules/apps/icingaweb2.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/apps/icingaweb2.nix b/modules/apps/icingaweb2.nix
index ed52f86..afb7712 100644
--- a/modules/apps/icingaweb2.nix
+++ b/modules/apps/icingaweb2.nix
@@ -5,7 +5,7 @@ let
inherit (lib) types
mkIf mkOption mkEnableOption mkDefault hasPrefix
concatMapStringsSep filterAttrs recursiveUpdate mapAttrsToList
- concatStringsSep isString filter genAttrs attrNames
+ concatStringsSep isString genAttrs attrNames
optionalString mkOptionType any;
inherit (types)
bool str int lines path either
@@ -245,9 +245,8 @@ let
fi
'';
- keys = filter (p: p != null && hasPrefix "/run/keys/" p)
- [ cfg.resources.icingaweb2db.passfile
- cfg.resources.icinga2db.passfile ];
+ keys = [ cfg.resources.icingaweb2db.passfile
+ cfg.resources.icinga2db.passfile ];
in {