aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/logrotate.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2017-04-30 14:42:55 +0300
committerIgor Pashev <pashev.igor@gmail.com>2017-04-30 15:56:41 +0300
commit9be6c7b78f2a668aa1edcafa25c3dd1ba8ae6ad7 (patch)
tree8db0743d00f83406e38e2c2c192751c778fe54c9 /modules/apps/logrotate.nix
parent49659d55878d09827566902d07d01f051926aff2 (diff)
downloadnixsap-9be6c7b78f2a668aa1edcafa25c3dd1ba8ae6ad7.tar.gz
(* BREAKING *) Avoid ambiguous options
"either foo (listOf foo)" was not very useful and interfered proper merging.
Diffstat (limited to 'modules/apps/logrotate.nix')
-rw-r--r--modules/apps/logrotate.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/apps/logrotate.nix b/modules/apps/logrotate.nix
index e7e360a..ba4ca5b 100644
--- a/modules/apps/logrotate.nix
+++ b/modules/apps/logrotate.nix
@@ -6,7 +6,7 @@ let
elem isBool isString ;
inherit (lib)
- concatMapStringsSep concatStringsSep filter filterAttrs flatten
+ concatMapStringsSep concatStringsSep filter filterAttrs
mapAttrsToList mkIf mkOption optionalString ;
inherit (lib.types)
@@ -21,7 +21,7 @@ let
mkConf = name: opts:
let
- files = concatMapStringsSep " " (f: ''"${f}"'') (flatten [opts.files]);
+ files = concatMapStringsSep " " (f: ''"${f}"'') opts.files;
show = k: v:
if elem k ["postrotate" "preremove" "prerotate"]
then " ${k}\n ${v}\n endscript"
@@ -48,7 +48,7 @@ let
entry = {
options = {
- files = mandatory (either path (listOf path));
+ files = mandatory (listOf path);
directives = {
compress = optional bool;
compresscmd = optional path;