aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/mysqlbackup.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:21:52 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:27:34 +0300
commitb40e89f23632d3fabe95bbf214bb77a32567b3d9 (patch)
treea76f8222e93152f3886008ad6ef7b6eadbe401ba /modules/apps/mysqlbackup.nix
parentb24ae5d345aa84bdba20efbb4a14ddfc9bf39873 (diff)
downloadnixsap-b40e89f23632d3fabe95bbf214bb77a32567b3d9.tar.gz
Do not filter keys at application level
It's done in the nixsap.deployment module See b24ae5d345aa84bdba20efbb4a14ddfc9bf39873
Diffstat (limited to 'modules/apps/mysqlbackup.nix')
-rw-r--r--modules/apps/mysqlbackup.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/apps/mysqlbackup.nix b/modules/apps/mysqlbackup.nix
index 509e010..e7d81eb 100644
--- a/modules/apps/mysqlbackup.nix
+++ b/modules/apps/mysqlbackup.nix
@@ -1,6 +1,6 @@
{ config, pkgs, lib, ... }:
let
- inherit (lib) mkOption mkIf mkDefault mapAttrsToList flatten hasPrefix filter
+ inherit (lib) mkOption mkIf mkDefault mapAttrsToList flatten hasPrefix
concatMapStringsSep concatStringsSep optionalString filterAttrs
splitString removeSuffix;
inherit (lib.types) bool str int path either enum nullOr listOf attrsOf submodule;
@@ -99,7 +99,7 @@ let
);
connectionKeys = flatten (mapAttrsToList (_: s: with s.connection; [ password-file ssl-key ]) cfg.servers);
- keys = filter (f: f != null && hasPrefix "/run/keys/" f) ( connectionKeys ++ [cfg.s3cfg] );
+ keys = connectionKeys ++ [ cfg.s3cfg ];
showDatabases = name: server: pkgs.writeText "show-databases-${name}.sql" ''
SHOW DATABASES WHERE `Database` NOT IN ('information_schema', 'performance_schema', 'tmp', 'innodb')