aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/mywatch.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:21:52 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:27:34 +0300
commitb40e89f23632d3fabe95bbf214bb77a32567b3d9 (patch)
treea76f8222e93152f3886008ad6ef7b6eadbe401ba /modules/apps/mywatch.nix
parentb24ae5d345aa84bdba20efbb4a14ddfc9bf39873 (diff)
downloadnixsap-b40e89f23632d3fabe95bbf214bb77a32567b3d9.tar.gz
Do not filter keys at application level
It's done in the nixsap.deployment module See b24ae5d345aa84bdba20efbb4a14ddfc9bf39873
Diffstat (limited to 'modules/apps/mywatch.nix')
-rw-r--r--modules/apps/mywatch.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/apps/mywatch.nix b/modules/apps/mywatch.nix
index 732033c..2698ba5 100644
--- a/modules/apps/mywatch.nix
+++ b/modules/apps/mywatch.nix
@@ -1,7 +1,7 @@
{ config, pkgs, lib, ... }:
let
- inherit (builtins) filter toString;
+ inherit (builtins) toString;
inherit (lib) types mkOption mkEnableOption mkIf hasPrefix
concatStrings optionalString;
inherit (types) str path int nullOr;
@@ -16,8 +16,6 @@ let
" '${cfg.myFile}'"
];
- keys = filter (f: f != null && hasPrefix "/run/keys/" f) [ cfg.myFile ];
-
in {
options.nixsap.apps.mywatch = {
enable = mkEnableOption "MyWatch";
@@ -44,7 +42,7 @@ in {
config = mkIf cfg.enable {
nixsap.system.users.daemons = [ cfg.user ];
- nixsap.deployment.keyrings.${cfg.user} = keys;
+ nixsap.deployment.keyrings.${cfg.user} = [ cfg.myFile ];
systemd.services.mywatch = {
description = "watch queries on multiple MySQL servers";
wantedBy = [ "multi-user.target" ];