aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/sproxy2.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-11-22 00:29:37 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-11-22 00:29:37 +0300
commit2366154ed35d3d20efaa27638355fb51255e2a43 (patch)
tree32b5423e4b9642085920d8303edde38856f00624 /modules/apps/sproxy2.nix
parent40e814980803c55e6c6b72328c87107ca4953064 (diff)
downloadnixsap-2366154ed35d3d20efaa27638355fb51255e2a43.tar.gz
sproxy2: added the key parameter
Diffstat (limited to 'modules/apps/sproxy2.nix')
-rw-r--r--modules/apps/sproxy2.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/apps/sproxy2.nix b/modules/apps/sproxy2.nix
index de95847..da4f0e8 100644
--- a/modules/apps/sproxy2.nix
+++ b/modules/apps/sproxy2.nix
@@ -128,6 +128,11 @@ in {
type = enum [ "error" "warn" "info" "debug" ];
default = "info";
};
+ key = mkOption {
+ description = "File with a key used to sign cookies and state (secret)";
+ type = nullOr path;
+ default = null;
+ };
database = mkOption {
description = "PostgreSQL connection string";
type = nullOr str;