aboutsummaryrefslogtreecommitdiff
path: root/pkgs/ldapply
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/ldapply
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/ldapply')
-rw-r--r--pkgs/ldapply/default.nix11
-rw-r--r--pkgs/ldapply/ldap.nix14
-rw-r--r--pkgs/ldapply/main.nix16
3 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/ldapply/default.nix b/pkgs/ldapply/default.nix
new file mode 100644
index 0000000..6bd1219
--- /dev/null
+++ b/pkgs/ldapply/default.nix
@@ -0,0 +1,11 @@
+{ haskell, haskellPackages }:
+
+let myHaskellPkgs = haskellPackages.override {
+ overrides = self: super: {
+ LDAP = self.callPackage ./ldap.nix { }; # Version with ldapExternalSaslBind
+ ldif = haskell.lib.dontCheck super.ldif; # requires ancient HUnit == 1.2.*
+ };
+};
+
+in myHaskellPkgs.callPackage ./main.nix { }
+
diff --git a/pkgs/ldapply/ldap.nix b/pkgs/ldapply/ldap.nix
new file mode 100644
index 0000000..03a5fd3
--- /dev/null
+++ b/pkgs/ldapply/ldap.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, HUnit, cyrus_sasl, openldap, stdenv }:
+mkDerivation {
+ pname = "LDAP";
+ version = "0.6.11";
+ doCheck = false; # XXX: missing file in tarball
+ sha256 = "1cwh3272zi5r0zznmixghf87vskz7s35bmz6ifyky0xk3s04ijq1";
+ libraryHaskellDepends = [ base ];
+ librarySystemDepends = [ cyrus_sasl openldap ];
+ testHaskellDepends = [ base HUnit ];
+ testSystemDepends = [ openldap ];
+ homepage = "https://github.com/ezyang/ldap-haskell";
+ description = "Haskell binding for C LDAP API";
+ license = stdenv.lib.licenses.bsd3;
+}
diff --git a/pkgs/ldapply/main.nix b/pkgs/ldapply/main.nix
new file mode 100644
index 0000000..3a69576
--- /dev/null
+++ b/pkgs/ldapply/main.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, bytestring, docopt, interpolatedstring-perl6
+, LDAP, ldif, stdenv, unordered-containers
+}:
+mkDerivation {
+ pname = "ldapply";
+ version = "0.2.0";
+ sha256 = "0qgpb22k9krdhwjydzyfhjf85crxc49ss7x74mrqj8ivkzg5hl28";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bytestring docopt interpolatedstring-perl6 LDAP ldif
+ unordered-containers
+ ];
+ description = "LDIF idempotent apply tool";
+ license = stdenv.lib.licenses.mit;
+}