aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sproxy-web
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/sproxy-web
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/sproxy-web')
-rw-r--r--pkgs/sproxy-web/cabal2nix.nix22
-rw-r--r--pkgs/sproxy-web/default.nix4
2 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/sproxy-web/cabal2nix.nix b/pkgs/sproxy-web/cabal2nix.nix
new file mode 100644
index 0000000..0583964
--- /dev/null
+++ b/pkgs/sproxy-web/cabal2nix.nix
@@ -0,0 +1,22 @@
+{ mkDerivation, aeson, base, blaze-html, blaze-markup, bytestring
+, data-default-class, directory, docopt, fast-logger, filepath
+, http-types, interpolatedstring-perl6, mtl, network
+, postgresql-simple, resource-pool, scotty, stdenv, text, unix, wai
+, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "sproxy-web";
+ version = "0.4.1";
+ sha256 = "0jvkvk5yqp4gibg61q67iczaqvfszikxvvgf04fg6xs23gjkpihp";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base blaze-html blaze-markup bytestring data-default-class
+ directory docopt fast-logger filepath http-types
+ interpolatedstring-perl6 mtl network postgresql-simple
+ resource-pool scotty text unix wai wai-extra wai-middleware-static
+ warp
+ ];
+ description = "Web interface to sproxy database";
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/pkgs/sproxy-web/default.nix b/pkgs/sproxy-web/default.nix
new file mode 100644
index 0000000..4afc645
--- /dev/null
+++ b/pkgs/sproxy-web/default.nix
@@ -0,0 +1,4 @@
+{ stdenv, haskellPackages }:
+
+haskellPackages.callPackage ./cabal2nix.nix {}
+