aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/jenkins/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/apps/jenkins/default.nix')
-rw-r--r--modules/apps/jenkins/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/modules/apps/jenkins/default.nix b/modules/apps/jenkins/default.nix
index 8bf230a..bd69477 100644
--- a/modules/apps/jenkins/default.nix
+++ b/modules/apps/jenkins/default.nix
@@ -107,6 +107,8 @@ let
-DJENKINS_HOME='${cfg.home}' \
${optionalString (properties.hudson.model.DirectoryBrowserSupport.CSP != null)
''-Dhudson.model.DirectoryBrowserSupport.CSP="${properties.hudson.model.DirectoryBrowserSupport.CSP}"''} \
+ ${optionalString (properties.java.util.logging.config.file != null)
+ "-Djava.util.logging.config.file='${properties.java.util.logging.config.file}'"} \
-Djava.io.tmpdir='${properties.java.io.tmpdir}' \
-jar '${cfg.war}' \
${concatStringsSep " \\\n " (mapAttrsToList mkOpt (explicit cfg.options))}