aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/jenkins/instance.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/apps/jenkins/instance.nix')
-rw-r--r--modules/apps/jenkins/instance.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/apps/jenkins/instance.nix b/modules/apps/jenkins/instance.nix
index 6cca8a4..89c5c93 100644
--- a/modules/apps/jenkins/instance.nix
+++ b/modules/apps/jenkins/instance.nix
@@ -62,6 +62,15 @@ in {
default = true;
};
+ nodes = mkOption {
+ description = ''
+ Nodes. Each value is either inline XML text or an XML file.
+ Any existing nodes, not mentioned here, are physically removed.
+ '';
+ type = attrsOf (either str path);
+ default = {};
+ };
+
jobs = mkOption {
description = ''
Jenkins jobs. Each value is either inline XML text or an XML file.