aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/sproxy-web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/apps/sproxy-web.nix')
-rw-r--r--modules/apps/sproxy-web.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/apps/sproxy-web.nix b/modules/apps/sproxy-web.nix
index 351e82d..04ddcdf 100644
--- a/modules/apps/sproxy-web.nix
+++ b/modules/apps/sproxy-web.nix
@@ -4,7 +4,7 @@ let
inherit (builtins) toString ;
inherit (lib)
- concatStrings filter hasPrefix mkEnableOption mkIf mkOption
+ concatStrings hasPrefix mkEnableOption mkIf mkOption
optionalString types ;
inherit (types)
int nullOr path str ;
@@ -19,8 +19,6 @@ let
else " -s '${cfg.socket}'")
];
- keys = filter (f: f != null && hasPrefix "/run/keys/" f) [ cfg.pgPassFile ];
-
in {
options.nixsap.apps.sproxy-web = {
enable = mkEnableOption "Sproxy Web";
@@ -53,7 +51,7 @@ in {
config = mkIf cfg.enable {
nixsap.system.users.daemons = [ cfg.user ];
- nixsap.deployment.keyrings.${cfg.user} = keys;
+ nixsap.deployment.keyrings.${cfg.user} = [ cfg.pgPassFile ];
systemd.services.sproxy-web = {
description = "Web interface to Sproxy database";
wantedBy = [ "multi-user.target" ];