aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/icinga2/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pkgs/icinga2/default.nix')
-rw-r--r--modules/pkgs/icinga2/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/modules/pkgs/icinga2/default.nix b/modules/pkgs/icinga2/default.nix
index 0816fce..c7967f9 100644
--- a/modules/pkgs/icinga2/default.nix
+++ b/modules/pkgs/icinga2/default.nix
@@ -2,6 +2,7 @@
, bison, boost, cmake, flex
, libedit, mariadb, postgresql
, openssl, yajl, pkgconfig
+, makeWrapper
}:
stdenv.mkDerivation rec {
@@ -14,8 +15,8 @@ stdenv.mkDerivation rec {
};
buildInputs = [
- bison boost cmake flex libedit mariadb.client openssl pkgconfig
- postgresql yajl
+ bison boost cmake flex libedit makeWrapper mariadb.client openssl
+ pkgconfig postgresql yajl
];
patches = [
@@ -43,6 +44,10 @@ stdenv.mkDerivation rec {
for s in $out/icinga2/etc/icinga2/scripts/* ; do
substituteInPlace $s --replace /usr/bin/printf printf
done
+
+ wrapProgram $out/lib/icinga2/sbin/icinga2 \
+ --prefix LD_LIBRARY_PATH : $out/lib/icinga2
+
rm -vf $out/sbin/icinga2
ln -svf $out/lib/icinga2/sbin/icinga2 $out/sbin/icinga2
test -x $out/sbin/icinga2