aboutsummaryrefslogtreecommitdiff
path: root/pkgs/check_aws_ec2_elb/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/check_aws_ec2_elb/default.nix')
-rw-r--r--pkgs/check_aws_ec2_elb/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/pkgs/check_aws_ec2_elb/default.nix b/pkgs/check_aws_ec2_elb/default.nix
deleted file mode 100644
index 5162c9d..0000000
--- a/pkgs/check_aws_ec2_elb/default.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ stdenv, pkgs, makeWrapper }:
-
-stdenv.mkDerivation {
- name = "check_aws_ec2_elb";
- outputs = [ "out" "conf" ];
- unpackPhase = ":";
- nativeBuildInputs = [ makeWrapper ];
- installPhase = ''
- mkdir -p $out/bin
-
- cp ${./check_aws_ec2_elb} $out/bin/check_aws_ec2_elb
- cp ${./check_aws_ec2_elb.conf} $conf
-
- chmod +x "$out/bin/"*
-
- substituteInPlace "$conf" \
- --replace check_aws_ec2_elb "$out/bin/check_aws_ec2_elb"
-
- wrapProgram "$out/bin/check_aws_ec2_elb" \
- --prefix PATH : "${pkgs.awscli}/bin:${pkgs.gnused}/bin:${pkgs.jq}/bin:${pkgs.bind}/bin"
- '';
-}