aboutsummaryrefslogtreecommitdiff
path: root/pkgs/check_mdstat/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/check_mdstat/default.nix')
-rw-r--r--pkgs/check_mdstat/default.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/pkgs/check_mdstat/default.nix b/pkgs/check_mdstat/default.nix
deleted file mode 100644
index 5e645fd..0000000
--- a/pkgs/check_mdstat/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ stdenv, gawk, gnugrep }:
-
-stdenv.mkDerivation {
- name = "check_mdstat";
- src = ./check_mdstat;
- outputs = [ "out" "conf" ];
- unpackPhase = ":";
- installPhase = ''
- mkdir -p $out/bin
-
- cp "$src" $out/bin/check_mdstat
-
- substituteInPlace "$out/bin/"* \
- --replace awk '${gawk}/bin/awk' \
- --replace grep '${gnugrep}/bin/grep'
-
- chmod +x "$out/bin/"*
-
- cat <<CONF > $conf
- object CheckCommand "mdstat" {
- import "plugin-check-command"
- command = [ "$out/bin/check_mdstat" ]
- }
- CONF
- '';
-}