aboutsummaryrefslogtreecommitdiff
path: root/pkgs/check_systemd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/check_systemd/default.nix')
-rw-r--r--pkgs/check_systemd/default.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/pkgs/check_systemd/default.nix b/pkgs/check_systemd/default.nix
deleted file mode 100644
index da92a64..0000000
--- a/pkgs/check_systemd/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ stdenv, gnused }:
-
-stdenv.mkDerivation {
- name = "check_systemd";
- src = ./check_systemd;
- outputs = [ "out" "conf" ];
- unpackPhase = ":";
- installPhase = ''
- mkdir -p $out/bin
-
- cp "$src" $out/bin/check_systemd
-
- substituteInPlace "$out/bin/"* \
- --replace sed '${gnused}/bin/sed'
-
- chmod +x "$out/bin/"*
-
- cat <<CONF > $conf
- object CheckCommand "systemd" {
- import "plugin-check-command"
- command = [ "$out/bin/check_systemd" ]
- }
- CONF
- '';
-}