aboutsummaryrefslogtreecommitdiff
path: root/pkgs/icingaweb2/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/icingaweb2/default.nix')
-rw-r--r--pkgs/icingaweb2/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/icingaweb2/default.nix b/pkgs/icingaweb2/default.nix
new file mode 100644
index 0000000..263ae47
--- /dev/null
+++ b/pkgs/icingaweb2/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl
+, php
+}:
+
+stdenv.mkDerivation rec {
+ version = "2.3.4";
+ name = "icingaweb2-${version}";
+
+ src = fetchurl {
+ url = "https://github.com/Icinga/icingaweb2/archive/v${version}.tar.gz";
+ sha256 = "0kmxvwbr7g6daj2mqabzvmw3910igd85wrzwilkz83fizgmrszh5";
+ };
+
+ buildInputs = [ php ];
+
+ patches = [ ./sproxy.patch ];
+
+ buildPhase = "true";
+
+ installPhase = ''
+ mkdir -p $out
+ cp -a * $out
+ rm -rf $out/.puppet
+ rm -rf $out/Vagrantfile
+ rm -rf $out/icingaweb2.spec
+ rm -rf $out/modules/doc
+ rm -rf $out/modules/iframe
+ rm -rf $out/modules/setup
+ rm -rf $out/modules/test
+ rm -rf $out/packages
+ rm -rf $out/test
+ '';
+}