aboutsummaryrefslogtreecommitdiff
path: root/pkgs/probes.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/probes.nix')
-rw-r--r--pkgs/probes.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/pkgs/probes.nix b/pkgs/probes.nix
deleted file mode 100644
index 650c996..0000000
--- a/pkgs/probes.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, pkgs, lib }:
-
-let
- plugins = [
- "check_disk"
- "check_file_age"
- "check_http"
- "check_load"
- "check_log"
- "check_mysql"
- "check_mysql_query"
- "check_procs"
- "check_swap"
- "check_users"
- ];
-
-in stdenv.mkDerivation {
- name = "local-monitoring-plugins";
- phases = [ "installPhase" ];
- installPhase = ''
- mkdir -p $out/bin
- ${lib.concatMapStringsSep "\n" (p: ''
- cp -a ${pkgs.monitoringPlugins}/libexec/${p} $out/bin/${p}
- '') plugins}
- cp -a '${pkgs.check_mdstat}/bin/'* $out/bin/
- cp -a '${pkgs.check_systemd}/bin/'* $out/bin/
- '';
-}