aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sproxy-web/cabal2nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sproxy-web/cabal2nix.nix')
-rw-r--r--pkgs/sproxy-web/cabal2nix.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/sproxy-web/cabal2nix.nix b/pkgs/sproxy-web/cabal2nix.nix
new file mode 100644
index 0000000..0f475f2
--- /dev/null
+++ b/pkgs/sproxy-web/cabal2nix.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, base, blaze-html, blaze-markup, bytestring
+, data-default-class, directory, docopt, fast-logger, fetchgit
+, filepath, http-types, interpolatedstring-perl6, mtl, network
+, postgresql-simple, resource-pool, scotty, stdenv, text, unix, wai
+, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "sproxy-web";
+ version = "0.4.1";
+ src = fetchgit {
+ url = "https://github.com/zalora/sproxy-web.git";
+ sha256 = "529597548a3fbd0999acdbd3a382ed4f152043db01f275b08d4c4883b8fe5f5f";
+ rev = "5d7ee61deb55359ae8ce6013dd7fe81bcdc0f9a9";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base blaze-html blaze-markup bytestring data-default-class
+ directory docopt fast-logger filepath http-types
+ interpolatedstring-perl6 mtl network postgresql-simple
+ resource-pool scotty text unix wai wai-extra wai-middleware-static
+ warp
+ ];
+ description = "Web interface to sproxy database";
+ license = stdenv.lib.licenses.mit;
+}