aboutsummaryrefslogtreecommitdiff
path: root/npmPackages/balanced-match/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'npmPackages/balanced-match/default.nix')
-rw-r--r--npmPackages/balanced-match/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/npmPackages/balanced-match/default.nix b/npmPackages/balanced-match/default.nix
new file mode 100644
index 0000000..309a461
--- /dev/null
+++ b/npmPackages/balanced-match/default.nix
@@ -0,0 +1,27 @@
+{ fetchurl, buildNpmPackage, matcha, tape }:
+
+buildNpmPackage {
+ pname = "balanced-match";
+ version = "1.0.0";
+ src = fetchurl {
+ url = "https://github.com/juliangruber/balanced-match/archive/v1.0.0.tar.gz";
+ sha256 = "0sqzdfnjqyw0kbwf459jwn7yds5gyf4b3jnr7779f79pqkngk86j";
+ };
+
+ meta = {
+ description = "Match balanced character pairs, like \"{\" and \"}\"";
+ homepage = "https://github.com/juliangruber/balanced-match";
+ license = "MIT";
+ };
+
+ npmInputs = [
+ matcha tape
+ ];
+
+ jailbreak = true;
+
+ files = [
+ "index.js"
+ ];
+}
+