aboutsummaryrefslogtreecommitdiff
path: root/npmPackages/file-uri-to-path/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'npmPackages/file-uri-to-path/default.nix')
-rw-r--r--npmPackages/file-uri-to-path/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/npmPackages/file-uri-to-path/default.nix b/npmPackages/file-uri-to-path/default.nix
new file mode 100644
index 0000000..fdd5e41
--- /dev/null
+++ b/npmPackages/file-uri-to-path/default.nix
@@ -0,0 +1,28 @@
+{ fetchurl, buildNpmPackage, mocha }:
+
+buildNpmPackage {
+ pname = "file-uri-to-path";
+ version = "1.0.0";
+ src = fetchurl {
+ url = "https://github.com/TooTallNate/file-uri-to-path/archive/1.0.0.tar.gz";
+ sha256 = "0jqdcichbcb73d7bwjng9grycwhqiaz9777nm4bxska4qbrvxx2f";
+ };
+
+ meta = {
+ description = "Convert a file: URI to a file path";
+ homepage = "https://github.com/TooTallNate/file-uri-to-path";
+ license = "MIT";
+ };
+
+ npmInputs = [
+ mocha
+ ];
+
+ files = [
+ "index.d.ts"
+ "index.ts"
+ ];
+
+ jailbreak = true;
+}
+