aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2022-09-24 13:11:05 +0200
committerIgor Pashev <pashev.igor@gmail.com>2022-09-24 13:11:05 +0200
commit8493dba7ff2f553ff9756ce868dc85254b767b4d (patch)
tree82a28b9276892bdc1947fd58f0637c949c4c7cbc /setup.py
parent249f59c4bfd1d20f81c7dc968988be98fe2398c3 (diff)
downloadyoso-master.tar.gz
Format with BlackHEADmaster
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 22 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 285cdea..afe7f10 100644
--- a/setup.py
+++ b/setup.py
@@ -1,33 +1,29 @@
from setuptools import setup, find_packages
setup(
- name = 'YOSO',
- version = '0.1.1',
- description = 'You Only Show Once',
- long_description = 'A GUI tool to create training data for YOLO network by Darknet. See <http://pjreddie.com/darknet/yolo/>.',
- author = 'Igor Pashev',
- author_email = 'pashev.igor@gmail.com',
- license = 'WTFPL',
- data_files = [('', [ 'LICENSE', 'ChangeLog.rst' ])],
-
- classifiers = [
- 'Development Status :: 3 - Alpha',
- 'Environment :: X11 Applications :: Qt',
- 'Intended Audience :: Science/Research',
- 'License :: Public Domain',
- 'Programming Language :: Python :: 3.5',
- 'Topic :: Multimedia :: Graphics :: Viewers',
- 'Topic :: Scientific/Engineering :: Visualization',
- 'Topic :: Utilities',
+ name="YOSO",
+ version="0.1.1",
+ description="You Only Show Once",
+ long_description="A GUI tool to create training data for YOLO network by Darknet. See <http://pjreddie.com/darknet/yolo/>.",
+ author="Igor Pashev",
+ author_email="pashev.igor@gmail.com",
+ license="WTFPL",
+ data_files=[("", ["LICENSE", "ChangeLog.rst"])],
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Environment :: X11 Applications :: Qt",
+ "Intended Audience :: Science/Research",
+ "License :: Public Domain",
+ "Programming Language :: Python :: 3.5",
+ "Topic :: Multimedia :: Graphics :: Viewers",
+ "Topic :: Scientific/Engineering :: Visualization",
+ "Topic :: Utilities",
],
-
- packages = find_packages(),
-
- install_requires = [ 'PyQt5' ],
-
- entry_points = {
- 'console_scripts': [
- 'yoso=YOSO:main',
+ packages=find_packages(),
+ install_requires=["PyQt5"],
+ entry_points={
+ "console_scripts": [
+ "yoso=YOSO:main",
],
},
)